分类 Mac 下的文章

更新到phpstorm for mac 2018版,发现svn不好使了,具体报错svn: E155036: Please see the 'svn upgrade' command svn: E155036: The working copy at '/Users/kaizhang/work/yourFileName' is too old (format 29) to work with client version '1.9.7 (r1800392)' (expects format 31). You need to upgrade the working copy first.如下图:

1533003546678.jpg

不要慌,这个错误灰常简单,“/Users/kaizhang/work/yourFileName”的工作副本太旧(格式29),无法使用客户端版本“1.9.7 (r1800392)”(预期格式31)。您需要先升级工作副本。

怎么解决呢?

只需要点击旁边的Subversion Working Copies Iformation,然后点击Change,选择1.8format就OK了。
具体操作如下图:
1533004286293.jpg

怎么样,是不是很简单?